AviUtl+拡張編集を使って研究結果の動画を作成する手順などについて.



AviUtlのインストール

  1. AviUtlのお部屋から最新版のAviUtl(aviutl*.zip)と 拡張編集プラグイン(exedit*.zip)をダウンロードする.
  2. aviutl*.zipを解凍.適当なフォルダに配置する.
  3. exedit*.zipを解凍して,中のファイルをaviutlのフォルダに移動(aviutl.exeとおなじフォルダ).
  4. aviutl.exeを実行.

各機能と操作

拡張編集ウィンドウを含めたウィンドウ構成を以下に示す.

aviutl_main.jpg

各ウインドウについては,

  • メインウィンドウ : AviUtlのウィンドウ.編集途中での確認やカット編集などを行う.
  • 拡張編集ウィンドウ : 左右に時間軸,上下にレイヤが並んだタイムライン編集を行うためのウィンドウ. 動画や画像,テキストを配置して全体の構成を行う.このウィンドウの表示/非表示は「設定」メニューの「拡張編集の設定」. 上部の数値は時間を示し,クリックすることでその位置での結果がメインウィンドウに表示される.
  • 再生ウィンドウ : 編集結果を確認するためのウィンドウ. 表示されていなければ,メインウィンドウのメニューから 表示 -> 再生ウィンドウの表示 を選択.
  • オブジェクトウィンドウ : 拡張編集ウィンドウでオブジェクトをダブルクリックすると出てくるウィンドウ. ウィンドウタイトルはオブジェクトごとにことなるので,ここではすべてまとめて「オブジェクトウィンドウ」と呼ぶ. オブジェクトの配置やフィルタの追加・編集を行うことができる. 最上部のバーはオブジェクトの開始位置と終了位置を示している. 上記の画像では開始位置が61フレーム,終了位置が232フレーム.

拡張編集ウィンドウ上での操作

拡張編集ウィンドウ上ではオブジェクトをD&Dで移動させることができる. その他の操作について以下に示す.

  • Ctrl+左クリック : 複数選択.Ctrlを押したままドラッグで複数選択したまま移動. 何もないところをドラッグで範囲選択可能.ただし,Ctrlをはなすと選択解除されるので注意.
  • 上部のルーラー上でShift+左ドラッグ : 出力範囲設定
  • Alt+左ドラッグ : タイムライン表示位置移動
  • Ctrl+ホイール : タイムライン表示スケール変更

基本的な動画作成の流れ

プロジェクトの作成

拡張編集ウィンドウ上で右クリックして,「新規プロジェクトの作成」をクリックすると, 新規プロジェクトの作成ダイアログが表示される(下図).

aviutl_new.jpg

動画のサイズ,フレームレート,音声レートを設定してOKボタンを押す.

動画やテキストの配置

拡張編集ウィンドウ上にエクスプローラからD&Dすると動画や画像,音声ファイルなどをタイムライン上に配置できる. 拡張編集ウィンドウは左右方向が時間軸,上下に複数のレイヤが並んでいる. 下のレイヤのオブジェクトが前面になる.

オブジェクトの位置,サイズ変更

動画などのオブジェクトを拡張編集ウィンドウで左クリックで選択. 動画の場合,動画ファイルというウィンドウ(以下オブジェクトウィンドウ)が出るので,そこで位置や拡大率などの設定を行う. または,メインウィンドウ上でメディアオブジェクトを選択してD&Dで位置変更も可能.

aviutl_obj.jpg

X,Yで位置(中心が0,0),Z,拡大率でサイズを変更できる. これらの数値変更はスライダーで行えるほかに,数値部分をクリックすると直接キーボードから入力もできる. さらに数値の上で左ドラッグで左右に動かしても上下する.

また,オブジェクトウィンドウの右上の"+"ボタンを押すと,そのオブジェクトに対してフィルタを設定できる. 上図では色調補正とフェードのフィルタを追加している. フィルタを選択するとその設定がオブジェクトウィンドウに追加される.

複数の動画を並べる

複数の動画をタイムライン上の異なるレイヤに配置し,それぞれの動画のサイズと位置を調整することで, 動画を複数並べることができる(下図参照).

aviutl_multi.jpg

並べて描画したときのスクリーンショットは以下.

aviutl_multi2.jpg

テキストの追加

拡張編集ウィンドウを右クリック -> メディアオブジェクトの追加 -> テキスト

でテキストを追加できる.テキストの設定を行うオブジェクトウィンドウは以下.

aviutl_text.jpg

下部のテキストフォームに描画したい文字列を入力する. フォントの他に影付き,縁取り文字も設定できる.

背景色の変更

拡張編集ウィンドウを右クリック -> メディアオブジェクトの追加 -> 図形

で図形を追加し,オブジェクトウィンドウで「図形の種類」を「背景」にし, 色の設定で色を設定する.

シーンチェンジの設定

動画やシーン間のトランスレーションを設定したい場合,

拡張編集ウィンドウを右クリック -> フィルタオブジェクトの追加 -> シーンチェンジ

でシーンチェンジをタイムライン上に配置する. 効果を追加したい部分の下のレイヤで2つのオブジェクトの境界をまたがるように配置する. シーンチェンジオブジェクトを追加したレイヤの上のレイヤすべてに適用される.

aviutl_sc.jpg

プロジェクトの保存

メインウィンドウのメニューで

ファイル -> 編集プロジェクトの保存

でプロジェクトを保存できる(拡張子aup). 後で編集しなおしたい場合に備えて,一通り作成したらいったん保存しておく.

動画出力

メインウィンドウのメニューで

ファイル -> AVI出力

で編集した内容を動画として保存できる.

aviutl_output.jpg

AVI出力ウィンドウでは,ビデオ圧縮,オーディオ圧縮のコーデックを選択する. 上の図では動画の中間フォーマットとしてhuffyuvを用い,オーディオはなしにしてある.

ファイル名を入力して保存ボタンを押すと,メインウィンドウに戻り,AVI出力が始まる. 出力状況(進行パーセント,残り時間)はメインウィンドウのタイトルで確認できる.

aupファイルサンプル

  • タイトル->シーン説明->結果動画->シーン説明->動画の比較 の流れを設定したプロジェクトファイルを以下に置く. 動画の代わりに図形(四角形)を配置してあるので,それらを動画に置き換えて長さなどを調整する. 実際に出力した例を以下に置く. 出力にはx264guiExプラグインを使用した.
  • ワイプを使った比較のプロジェクトファイルを以下に置く. 動画の代わりに図形(四角形)を配置してあるので,それらを動画に置き換えて長さなどを調整する. 上から2番目と3番目の図形は同じ動画にすること. 実際に出力した例を以下に置く. 最初は動画1を表示し,ある時間に動画2を半分だけワイプで表示し,2つの動画を重ねて比較できるようにしてある. さらに時間がたつと動画2だけを表示する. 今のところ,後半部分をワイプにするために動画2に関しては同じものをタイムライン上に2つ配置する必要があるが, もっといい方法があるかもしれない.

TIPS

  • 拡張編集画面が出ない
    設定 -> 拡張編集の設定
  • メディアオブジェクトの一部分だけにフィルタを適用
    拡張編集ウィンドウを右クリック -> メディアオブジェクトの追加 -> フィルタ効果の追加
  • 選択メディアオブジェクトのみにフィルタを追加
    拡張編集ウィンドウからメディアオブジェクトを選択して,オブジェクト設定ウィンドウの右上の"+"ボタンでフィルタを追加
  • 短いオブジェクトの移動
    タイムライン上の短いオブジェクトだとドラッグするとリサイズと勘違いされ,移動しにくいときがある.
    そのようなときなCtrlを押しながらドラッグすると移動となる(複数選択モードではリサイズはできないため).

添付ファイル: filecomparison_with_wipe.mp4 994件 [詳細] fileresult.mp4 1094件 [詳細] fileresult.aup 1129件 [詳細] fileaviutl_multi2.jpg 1444件 [詳細] fileaviutl_output.jpg 1423件 [詳細] fileaviutl_multi.jpg 2102件 [詳細] fileaviutl_main.jpg 3481件 [詳細] fileaviutl_obj.jpg 1441件 [詳細] fileaviutl_sc.jpg 1381件 [詳細] filecomparison_with_wipe.aup 992件 [詳細] fileaviutl_text.jpg 1444件 [詳細] fileaviutl_new.jpg 628件 [詳細]

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2018-07-31 (火) 17:58:02 (790d)